WordPress … warum habe ich mir das nur angetan

Eigentlich bin ich eingefleischter S9y-Nutzer.
Kenne ich mich mit aus. Benutze ich seit Jahren und liebe den Support.

Mein Grundgedanke: „Du solltest mal Deine Google-Blogs in Deinen lokalen Blog aufnehmen“.
Soweit so gut. Zumindest theoretisch.
Praktisch erwies sich ein Import von Google in S9y allerdings mehr als problematisch.
Der Importer importierte zwar fröhlich vor sich hin, machte jedoch auch aus jedem Bild einen eigenen Eintrag, so dass ich tausende Einträge hätte prüfen und löschen müssen.

Noe, hatte ich keinen Bock drauf.
Kurz überlegt was man denn sonst mal testen kann (ich fahre ja einen root-Server mit beinahe unbegrenzten Platz), versuchte ich es mal mit WordPress.
Wordpress kam mir nur so in den Sinn. Eigentlich eher negativ, weil WP seit Anbeginn mit Sicherheitsproblemen zu kämpfen hat … aber was solls.
Also drauf damit und den Importer getestet.
Alle Blogs liessen sich ohne Probleme übernehmen, nichts war doppelt und dreifach oder mit Problemen bei Umlauten behaftet.
Na fein, geht doch.

Schnell (2 Tage) noch fehlende Einträge geschrieben und das Ganze angeschaut.

Joah, ist okay … aber … was ist das denn? Wieso kann ich die Bilder nur teilweise vergrössern lassen?
*grrrr

Nach ein wenig Suche im Netz kam ich dann dahinter das etwas in der aktuellen verschlimmbessert wurde. Doch damit nicht genug.
Anstatt beim Import aus den Googleblogs die Medien zu saugen, in die eigene Mediendatenbank zu integrieren und die Pfade der Bilder entsprechend umzugestalten, wurden die Medien nur mit dem Googleblog verlinkt.
Hallo??? Gehts noch??? Und wenn der Blog nun gelöscht wird, sind meine Tagebücher für den Arsch? Ganz tolle Leistung. Danke.

Also muss ich nun ein paar hundert Einträge einzeln prüfen, die Medien selber aus Google runter und auf meinen Server raufladen.

Aber selbst damit ist dann noch nicht Schluss. Noeee, wenn schon scheisse dann richtig scheisse.
Bilder die aus der Mediendatenbank in einen Blogeintrag einfügt werden, werden ohne Direktverlinkung zur Originalgrösse eingefügt.
Das bedeutet das man jedes einzelne Bild erneut anklicken, bearbeiten und verlinken muss, damit es im Blog dann anklickbar wird.
Man hat ja sonst nichts zu tun wenn man Artikel schreibt.
Nachtrag:
Die Lösung für dieses Problem muss man erst einmal finden, oder darauf kommen. WordPress merkt sich die letzte Einstellung wie ein Bild eingefügt wurde. Zu Beginn fügt es Bilder mittig, ohne Verlinkung ein.
Wenn man dann ein Bild linksbündig und direkt verlinkt auf das Medium einfügt, werden auch alle nachfolgenden Bilder so übernommen.

Aber nun habe ich diesen blöden Scheiss angefangen und muss zusehen das es fertig wird.